syntax error

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • syntax error

      Message: syntax error, unexpected '.', expecting '{'
      File: /includes/classes/cache/builder/BannedBuildCache.class.php
      Line: 18
      URL: owarz-game.de/install/index.php?mode=install&step=8
      PHP-Version: 7.1.17
      PHP-API: cgi-fcgi
      2Moons Version: 2.0.0 (FILE)
      Debug Backtrace:
      #0 /includes/common.php(103): require()
      #1 /install/index.php(45): require('FILEPATH ...')
      #2 {main}

      kann mir vieleicht einer helfen komme hier nicht weiter

      Display Spoiler

      <?php
      /**
      * 2Moons
      * by Jan-Otto Kröpke 2009-2016
      *
      * For the full copyright and license information, please view the LICENSE
      *
      * @package 2Moons
      * @author Jan-Otto Kröpke <slaver7@gmail.com>
      * @copyright 2009 Lucky
      * @copyright 2016 Jan-Otto Kröpke <slaver7@gmail.com>
      * @licence MIT
      * @version 1.8.0
      * @link github.com/jkroepke/2Moons
      */
      class BannedBuildCache implements BuildCache.interface
      {
      function buildCache()
      {
      $Data = Core::getDB()->query("SELECT userID, MAX(banTime) FROM ".BANNED." WHERE banTime > ".TIMESTAMP." GROUP BY userID;");
      $Bans = array();
      while($Row = $Data->fetchObject())
      {
      $Bans[$Row->userID] = $Row;
      }
      return $Bans;
      }
      }
    • how do you make so much mistake about 2moons knowing that no one has as much error as you
      I remain at your disposal on the forum for any questions or help.

      A help is of course not a creation of a mod



      -------------------------------------------------------
      Spaccon
      • Uni Xterium Comming Soon
      • Uni Ogame Comming Soon
    • Hi,
      nur als Tipp...
      Es hat meiner Meinung keinen Sinn, eine ältere 2Moons-Version zu installieren.
      Versionen vor der Versionen 1.8 nutzen kein PDO und sind zu deiner PHP Version nicht kompatiblen.

      Um ältere Versionen lauffähig zu bekommen, sind grundlegende Änderungen im Game notwendig und auch wenn Du das schaffst, hast Du dann eine veraltete Game-Version an laufen.
      Der ganze Aufwand ist es nicht wert.

      Nimm die aktuelle Version 1.8 von Jan oder die im Forum angebotete 2.0 Version und alles ist gut.
      Dafür gibt es auch Mods.
      Es ist wesentlich einfacher alte Mods für die aktuelle Version umzustellen, also eine alte Game-Version auf eine aktuelle PHP-Version umzuprogrammieren.

      Will Dir wirklich die Freude am Game nicht vermiesen, aber ich spreche aus langjähriger Erfahrung...

      Grüße...

      Racer
      myplanets.de | zeig dass DU es drauf hast, wir warten auf DICH ...
    • Da keiner hier deine Version oder sonst was kennt und dein Code nicht der aktuellen Version entspricht, kann ich dir nur sagen:


      class BannedBuildCache implements BuildCache.interface

      Sollte wohl eher class BannedBuildCache implements BuildCache sein, da wohl BuildCache.interface falsch ist und daher auch die { nicht passt.


      Trotzdem bezweifle ich, dass du diesen Code überhaupt verstehst und daher verstehe ich nicht wieso du so beharrlich daran weiter arbeitest, allerdings kein neues Wissen erlernen möchtest.