Install error Vers. 2.0

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Install error Vers. 2.0

      I am sucessfully running version 1.8
      but now i wanted to try version 2.0

      i installed PHP 7.2 and chenged it on my server. restarted apache2. as soon as i do that i have this error:

      Source Code

      1. Fatal error: Uncaught Error: Undefined class constant 'MYSQL_ATTR_INIT_COMMAND' in /var/www/html/includes/classes/Database.class.php:51 Stack trace: #0 /var/www/html/includes/classes/Database.class.php(30): Database->__construct() #1 /var/www/html/includes/classes/Config.class.php(78): Database::get() #2 /var/www/html/includes/classes/Config.class.php(55): Config::generateInstances() #3 /var/www/html/includes/GeneralFunctions.php(489): Config::get() #4 [internal function]: exceptionHandler(Object(Error)) #5 {main} thrown in /var/www/html/includes/classes/Database.class.php on line 51
      if return to PHP7.0 then the website works but everytime i want to log in, a popup window shows and tells me "Session expired".
      yes i know that version 2.0 is only working with PHP 7.2. i just wanted to mention.

      someone had the same problems?

      thank you
      randy aka. peroja
      Wenn das Leben wie eine Zitrone schmeckt, dann frag nach Salz und Tequilla
    • Although I did not have, I'd rather wait for php 7.2 some more few updates. Some server distribution compilations are not good enough with 7.2 yet.

      Don't know if you're using VPS or normal hosting.
      Looking for good VPS to host your game? Use DigitalOcean and get 10$ bonus credit!

      Private project - stellaron.space
    • Qwa wrote:

      Don't know if you're using VPS or normal hosting.
      i have a dedicated server. ubuntu 16.04 is running
      only this game is on the server. northing else
      Wenn das Leben wie eine Zitrone schmeckt, dann frag nach Salz und Tequilla
    • Hello during the coding I made on the version 2.0 I also made under dedicated with dabian 6.0. I also test under Ubuntu is it works fine. think about looking at the php extensions that are enabled
      I remain at your disposal on the forum for any questions or help.

      A help is of course not a creation of a mod



      -------------------------------------------------------
      Spaccon
      • Uni Xterium Comming Soon
      • Uni Ogame Comming Soon
    • New

      is PDO extension being loaded properly in ini? some server providers on their distros do not include extensions on php package
      Looking for good VPS to host your game? Use DigitalOcean and get 10$ bonus credit!

      Private project - stellaron.space
    • New

      Qwa wrote:

      is PDO extension being loaded properly in ini? some server providers on their distros do not include extensions on php package
      yes i already found out. no its not loaded. i will try later. thank you
      Wenn das Leben wie eine Zitrone schmeckt, dann frag nach Salz und Tequilla