Pinned List Mods Version 2.0

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Zeus wrote:

    I'm using php version 7.3 already in 2.0 version and when I do 7.4 I get an error
    Weird because I tested it under all php versions up to 8.1
  • Source Code: error.log

    1. WARNING
    2. Message: Trying to access array offset on value of type bool
    3. File: /includes/pages/game/AbstractGamePage.class.php
    4. Line: 253
    5. URL: https://xxxxxxxxxxxxx/game.php?page=quests
    6. PHP-Version: 8.0.26
    7. PHP-API: litespeed
    8. 2Moons Version: 2.0.git
    9. Debug Backtrace:
    10. #0 /includes/pages/game/AbstractGamePage.class.php(253): errorHandler(2, 'Trying to acces...', 'FILEPATH ...', 253)
    11. #1 /includes/pages/game/AbstractGamePage.class.php(266): AbstractGamePage->getNavigationData()
    12. #2 /includes/pages/game/AbstractGamePage.class.php(387): AbstractGamePage->getPageData()
    13. #3 /includes/pages/game/ShowQuestsPage.class.php(44): AbstractGamePage->display('page.quests.def...')
    14. #4 /game.php(57): ShowQuestsPage->show()
    15. #5 {main}
    Display All
    yes this is the error i get php version 8.0 ?
  • Zeus wrote:

    yes this is the error i get php version 8.0 ?
    question your mistake is made because the source code of the game does not work well under php 8
    In addition, you have touched the AbstrackGame file? because my mod does not touch it.
    To see the error be as Linkin mentions via the error.log or by looking in your console -> network then go to the quests page a red line with the call to the page will be red if there is a problem click on it to see the error message in Response
  • yes i fixed the problem i tried php version 7.3 and 7.4 still the same error.log file does not show empty error when i click on categories anywhere it seems active when i look from console but content is not displayed
  • not normal, did you use the files from my github?

    It is possible that this is the function that is bugging you

    fichier ShowQuestsAjaxPage.class.php

    search

    PHP Source Code

    1. function fleetVol($fleetId): int
    replace

    Source Code

    1. function fleetVol($fleetId)
  • Zeus wrote:

    2.0 version does not support php7.4 version and above. Which file did you update? where do we download
    just change what you put, no version 2.0 i made it a long time ago, the only version that will support php 8 will be version 3
  • Zeus wrote:

    It means we can't run the mods now. It is not clear when the version 3.0 you will do will be released.

    I didn't understand anything from this process
    So to make it simple all the mods available here are for v2
  • I installed 2.0 from scratch and as I mentioned in the php 7.3 version, the contents of the categories are not visible.

    also my server is timed
    but time is 3 hours behind me in the game
  • weird but is it related to the game time zone? Everything works for us, only when you click on the category, it says it's active, but it doesn't show its content from the console.
  • In the console how are the lines and did you return
    Images
    • Screenshot_142.png

      28.61 kB, 1,873×99, viewed 168 times
    • Screenshot_143.png

      21.88 kB, 1,585×85, viewed 150 times
    • Screenshot_144.png

      13.39 kB, 581×268, viewed 160 times
  • Bonjour à tous, pour les personne qui utilise mon mod Astéroïdes et qui on eux cette erreur régulièrement

    Message: SQLSTATE[22007]: Invalid datetime format: 1292 Truncated incorrect DOUBLE value: ''
    Query-Code:UPDATE uni1_fleets SET `fleet_resource_metal` = `fleet_resource_metal` + '0', `fleet_resource_crystal` = `fleet_resource_crystal` + '0', `fleet_resource_deuterium` = `fleet_resource_deuterium` + '' WHERE fleet_id = 16547;

    et suite à de nombreux signalement je me suis pencher un peux plus sur ce bug et je vous mes donc à jours ce mod avec le correctif.

    Je vous invite à télécharge à nouveau le mod via mon github.

    ----------------------------------------

    Hello everyone, for the people who use my Asteroids mod and who have this error regularly

    Message: SQLSTATE[22007]: Invalid datetime format: 1292 Truncated incorrect DOUBLE value: ''
    Query-Code:UPDATE uni1_fleets SET `fleet_resource_metal` = `fleet_resource_metal` + '0', `fleet_resource_crystal` = `fleet_resource_crystal` + '0', `fleet_resource_deuterium` = `fleet_resource_deuterium` + '' WHERE fleet_id = 16547;

    and following numerous reports I looked into this bug a bit more and I am therefore updating this mod with the fix.

    I invite you to download the mod again via my github.
  • @Danter14 el mod quest me esta dando este problema en el servidor pero sin embargo en el local me funciona perfectamente

    Source Code

    1. game.php:1 Uncaught SyntaxError: Unexpected token '<', "<!DOCTYPE "... is not valid JSON
    2. at JSON.parse (<anonymous>)
    3. at Function.parseJSON (jquery.js:514:23)
    4. at Object.success (quests.js?v=.git:37:27)
    5. at fire (jquery.js:974:30)
    6. at Object.fireWith [as resolveWith] (jquery.js:1084:7)
    7. at done (jquery.js:7803:14)
    8. at XMLHttpRequest.callback (jquery.js:8518:8)
    Alguna idea del porque me muestra este error y no se muestran las misiones
    VERY SAD :/ :/ :/ :/